CarAudioForum.com


Reply
Old 03-01-2005, 08:20 AM   #1
pimp boy

Registered User
 
Join Date: Feb 2005
Posts: 15
pimp boy is on a distinguished road



Need Help

I have a thunder 1501D amp pushing two 15" KOVE armaggedon sub's. I have a problem with my amp. My amp is turning on and off constantly. Even if the volume is way down. Can someone tell me what might caused the problem. thanks.
pimp boy is offline   Reply With Quote

Sponsored Links
Help Syrian Refugees Survive. Donate Now!
Or text REFUGEES to 50555 to give $10 to USA for UNHCR
Old 03-01-2005, 09:56 PM   #2
KicRocs

Registered User
 
Join Date: Mar 2005
Location: Orange County, CA
Posts: 5
KicRocs is on a distinguished road



Something may be wrong with the amp or your wiring. Your amp is going into protection mode. Double check your wiring. Make sure your positive wires are not being grounded. Check your sub wiring and make sure your amp can handle the ohms you wired your subs to.
KicRocs is offline   Reply With Quote

Old 03-03-2005, 10:54 AM   #3
pimp boy

Registered User
 
Join Date: Feb 2005
Posts: 15
pimp boy is on a distinguished road



The wires were wrong connected. How do you wire my 2 ohm subs to my mono amp? It would really help me. Thanks
pimp boy is offline   Reply With Quote

Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:46 PM.
Powered by vBulletin® - Copyright © 2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 1996 - 2011 by CarAudioForum.com - all rights reserved.